Print Preview ActiveX Active Users: 33 / Visits Today: 151
Highest Active Users: 33
Print Preview ActiveX
Home | Profile | Register | Active Topics | Members | Search | FAQ | RSS
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Print Preview
 Beta Testers
 PPreview 5.30
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic: Barcode 39 on pdf Topic Next Topic: Preview 5.29.1  

Waty Thierry
Forum Admin

Belgium
635 Posts

Posted - 08/03/2006 :  20:57:10  Show Profile  Visit Waty Thierry's Homepage  Reply with Quote
New version fixing some minor things,
Allowing also possibility to export to PDF bigger documents.

Download Attachment: [img]images/icon_paperclip.gif[/img] Preview5.zip
250.51 KB

Come and visit :
www.immoassist.com
www.ppreview.net
www.vbdiamond.com
www.d2dsources.com
www.mandix.com
Go to Bottom of Page

antari6675
Starting Member

24 Posts

Posted - 08/04/2006 :  02:30:48  Show Profile  Reply with Quote
I downloaded and placed the dll into the 5.28 folder. I get the following error now:

Class does not support Automation or does not support expected interface.

I get this error when I try to run your testOCX program, my test page program, and when I try to insert the ocx into the form.

Thanks for taking a look.


Edited by - antari6675 on 06/24/2012 08:39:00
Go to Bottom of PageGo to Top of Page

rgarito
Starting Member

USA
14 Posts

Posted - 08/15/2006 :  04:19:59  Show Profile  Reply with Quote
Try re-registering the DLL and/or OCX. This is often required when a new version of the Preview DLLs come out. To do this, do

regsvr32 preview.dll
regsvr32 preview5.ocx

(do this from the directory where the DLLs are kept).

Note that you will also need to do this on any machine that you re-distribute your code to. And, your code will most-likely need to be recompiled, although probably will not require any code changes.

Go to Bottom of PageGo to Top of Page

wbgookin
Junior Member

USA
113 Posts

Posted - 08/15/2006 :  14:39:20  Show Profile  Visit wbgookin's Homepage  Reply with Quote
You might also need to unregister the existing version first...I'm not sure.
regsvr32 -u preview.dll

Then put the new one in, and:
regsvr32 preview5.30.dll
Go to Bottom of PageGo to Top of Page

Waty Thierry
Forum Admin

Belgium
635 Posts

Posted - 09/11/2006 :  14:12:29  Show Profile  Visit Waty Thierry's Homepage  Reply with Quote
Here is the OCX, I forgot to put it too.

Try to always use the DLL.
DLL is always better than OCX.

Thierry

Download Attachment: [img]images/icon_paperclip.gif[/img] PreviewOCX.zip
295.38 KB

Come and visit :
www.immoassist.com
www.ppreview.net
www.vbdiamond.com
www.d2dsources.com
www.mandix.com
Go to Bottom of PageGo to Top of Page

wholeleaf
Starting Member

USA
12 Posts

Posted - 10/15/2006 :  04:55:49  Show Profile  Reply with Quote
quote:


Try to always use the DLL.
DLL is always better than OCX.




I have not been able to use the dll with FoxPro. Using the ocx, I can get all the way through the page layout and end document. Then nothing happens. Not even a waiting job in the printer part of the control panel. I have used ppreview with vb for a f ew years with some success. Is there a trick to using it with FoxPro?
Go to Bottom of PageGo to Top of Page

antari6675
Starting Member

24 Posts

Posted - 10/18/2006 :  08:36:25  Show Profile  Reply with Quote
I have not been able to use the updated dll or ocx. I still get a runtime error-91 when trying to run any code. I regsvr32 -u the old dll and ocx and regsvr32 the new.

Could you please provide a new install package. This is been very frustraiting.


Thank You


Edited by - antari6675 on 06/24/2012 08:39:23
Go to Bottom of PageGo to Top of Page

Waty Thierry
Forum Admin

Belgium
635 Posts

Posted - 11/05/2006 :  11:26:48  Show Profile  Visit Waty Thierry's Homepage  Reply with Quote
New full install posted on the main entry of the site

Come and visit :
www.immoassist.com
www.ppreview.net
www.vbdiamond.com
www.d2dsources.com
www.mandix.com
Go to Bottom of PageGo to Top of Page

diego
Starting Member

USA
1 Posts

Posted - 11/12/2006 :  20:00:00  Show Profile  Visit diego's Homepage  Reply with Quote
I am a registered user. I installed the 5.30 version from scratch and I am also getting the "Class does not support Automation or does not support expected interface." error. I unregister and re-register the dll and ocx but still the same result. I am using the installer download. Any way to fix this or I should go back to verrsion 5.28 for now?

Thanks.
Go to Bottom of PageGo to Top of Page
  Previous Topic: Barcode 39 on pdf Topic Next Topic: Preview 5.29.1  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Print Preview ActiveX © Mandix Go To Top Of Page
This page was generated in 0.09 seconds. Powered By: Snitz Forums 2000 Version 3.4.02