Print Preview ActiveX Active Users: 96 / Visits Today: 334
Highest Active Users: 99
Print Preview ActiveX
Home | Profile | Register | Active Topics | Members | Search | FAQ | RSS
 All Forums
 Print Preview
 Bugs
 DrawArrow not working right

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert Email Insert CodeInsert QuoteInsert List
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

   Insert a File

Check here to subscribe to this topic.
   

T O P I C    R E V I E W
wbgookin Posted - 04/06/2005 : 00:23:02
I'm having problems with the DrawArrow function in version 5.21.0:

1. drARSharp doesn't seem to work at all. If you use it, no arrow gets printed.

2. the order of the points for the line makes a big difference.
(a) The following shows the arrows with the pointy ends pointed outward:

prn.DrawArrow prARAngle, "0.1 in", -1, "0.1 in", "1 in", "1 in", "2 in", "2 in"

(b) This code, with the x1,y1 and x2,y2 reversed, shows backward arrow-heads:

prn.DrawArrow prARAngle, "0.1 in", prARAngle, "0.1 in", "2 in", "2 in", "1 in", "1 in"


In fact, the code from the help file has the arrow heads flipped:

.DrawArrow prARAngle, "10 pt", prAngle, "10 pt", "2.0 in", "3.0 in", "2.0 in", "5.0 in"

While you can fix that by making the size negative, I think the default should have the arrow heads pointed out unless the size is negative.

3. The sizeEnd variable doesn't do anything. It all is based on what the sizeStart is.

Hopefully these are easy fixes...

Bill
1   L A T E S T    R E P L I E S    (Newest First)
Waty Thierry Posted - 04/06/2005 : 11:23:10
Hi Bill, you're right, there is a bug.
I am fixhing it

Come and visit :
www.immoassist.com
www.ppreview.net
www.vbdiamond.com
www.d2dsources.com
www.mandix.com

Print Preview ActiveX © Mandix Go To Top Of Page
This page was generated in 0.05 seconds. Powered By: Snitz Forums 2000 Version 3.4.02